Avatar

Allegro and Carlson SurvCE (Land Surveying)

by ps8182 ⌂ @, Silver Lake, OH, Thursday, November 11, 2010, 10:40 (1665 days ago)

I have a Leica 1100 series robot that I run with an older Ranger 200C using TDS Survey Pro w/robotics ver. 4.5.3. The combination works okay, but seems to have some problems when the robot looses lock. The robot will go into ATR to try and regain lock, but never goes into a search pattern if that fails. I've been told this is problem with Survey Pro and the generic instrument driver that it uses for Leica TPS instruments. Anyways I've run into a used Allegro CE with a VGA screen running Carlson SurvCE ver 2.12 and have been told this is much better combo to use with a Leica Robot, however I have no experience with Allegro data collectors. Does anyone have any input on the collector or the combo to run a Leica robot.

Thanks

Avatar

Allegro and Carlson SurvCE

by foggyidea ⌂ @, Peoples Republic of Cape Cod, Thursday, November 11, 2010, 10:44 (1665 days ago) @ ps8182

I've been using the Allegro with SurvCE from Carlson for the past two and half years. I use it for my Sokkia GPS data collector and have had no problems with it so far. I like the Carlson programs and have been using the survey program since 2004.

If I were you I would take a good long hard look at the Allegro as your driver!!

--
GEOMAGICIAN
"Outstanding in the Field"

Donald T. Poole PLS MA#32662, CFedS#1499 (expired)
www.outermostlandsurvey.com
www.cfeds.org

Avatar

Allegro and Carlson SurvCE

by ps8182 ⌂ @, Silver Lake, OH, Thursday, November 11, 2010, 11:14 (1665 days ago) @ foggyidea

There is an Allegro CX and a CE available .....any preference?

Allegro and Carlson SurvCE

by Peter Kozub @, Thursday, November 11, 2010, 11:22 (1665 days ago) @ ps8182

I use a BW CX, new a year ago the version of carlson i have is
working well with the equipment in my profile
Go for the CX
One thing is the connection to GPS and Robot port there is a pause
1-3 sec just don't rush it with rapid fire button pushes or i will
lock up when it goes to the port fot data
or leaves the port.

Happy enough here with the CX

Peter K

Avatar

Allegro and Carlson SurvCE

by foggyidea ⌂ @, Peoples Republic of Cape Cod, Thursday, November 11, 2010, 11:25 (1665 days ago) @ ps8182

I have the CX and don't know anything about the CE.

One thing that I will say is that the juniper support rocks....Carlson, too.

--
GEOMAGICIAN
"Outstanding in the Field"

Donald T. Poole PLS MA#32662, CFedS#1499 (expired)
www.outermostlandsurvey.com
www.cfeds.org

Avatar

Leica Viva CS15

by Steve Corley @, Little Rock, Arkansas, Thursday, November 11, 2010, 17:57 (1664 days ago) @ foggyidea

We just bought a Leica Viva CS15 Data Collector to drive our new Leica Robot. I have been testing it out some and it looks like it will be easy to learn, and can do a lot of neat things. My one complaint is that "Sets of Angles" is an optional program.

--
Steve Corley
steve dot c dot corley at sbcglobal dot net

Leica Viva CS15

by Matthew Loessin ⌂ @, Columbus, TX, Thursday, November 11, 2010, 18:02 (1664 days ago) @ Steve Corley

Steve

We have been using the Viva units right at a year now and could not be more than happy. Smartworx 3.0 blows away any data collection program out there today and is supposed to get even better.

--
Matthew W. Loessin, RPLS

Avatar

Leica Viva CS15

by lattitudes, Alaska/Florida, Thursday, November 11, 2010, 22:22 (1664 days ago) @ Matthew Loessin

I am sure you will be pleased with the Allegro with Carlson on board. Seems much quicker than the Explorer II it replaced. Make sure robotics, roads, GPS etc are enabled.

Avatar

Allegro and Carlson SurvCE

by Dave Tlusty @, Langlade County, WI, Friday, November 12, 2010, 06:09 (1664 days ago) @ ps8182

There is an Allegro CX and a CE available .....any preference?

I use a color CX with MicroSurvey FieldGenius. The color screen is hard to see in any bright light and you're always doing some kind of moving around to see the screen better.

I also use a monochrome CE running SMI Version 8. With the two units side by side, the CE screen is much easier to see in bright light.

I prefer the CE/SMI combo over the CX with FG. MUCH more keystroke/poke efficient.

Allegro and Carlson SurvCE

by Kevin, Friday, November 12, 2010, 20:31 (1663 days ago) @ ps8182

The CE is the oldest, phased out 4 years ago +/-.
The CX was phased out about a year ago.
The MX is the current model Allegro.

SurvCe 2.XX will strain the CE.
1.67 will run ok on a CE and work with your 1100.
2.XX will run fine on most CXs, and all MXs.
2.52 is the current version.
2.XX can be upgraded to 2.52 for free.

Resale of "used" software is a conflict with the EULA of most software.

Does the Allegro have the Leica radio pod built in?
Is there a matching radio with it for the 1100?
It takes a different radio than the RCS1100 remote.
It looks the same, but has a different board inside.
The radios you are using with you Ranger may, or may not, work with the Allegro and Carlson SW.

The CX is a much better option than the CE. All of the Allegros are well built computers, but the CE is getting pretty old.

You can run SurvCe on your Ranger, although 1.67 may place too large of a demand on it.

I work for a dealer and service center for Leica, Carlson, and Allegro (Juniper) products. If you have any other questions; please let me know.

Avatar

Allegro and Carlson SurvCE

by ps8182 ⌂ @, Silver Lake, OH, Saturday, November 13, 2010, 13:24 (1662 days ago) @ Kevin

Thanks for the break down. I've been hearing that you can transfer ownership of the software via Carlson's website ...do you now anything about this? I've talked to some people that use the Leica 1100 robot with Carlson and are happy with it, but sounds like it may not be the answer to my problem. I'm currently using TDS SurveyPro which works fine and operates the Power Search without a flaw, however no matter what I set the search settings at in the collector or in the instrument for RCS Search Window or Define Work Area doesn't seem to have any affect on how the gun looks for the prism when lock is lost. Power Search is great, but is just one more button to push ...once in a while I would like to just stand there and have the gun go into a sweeping search pattern and find me instead of the ignorant little box it does a couple times. If I'm walking a go behind a tree it almost always comes out the otherside and finds me, if a car drives in between me and the gun the gun atomatically regains lock, however if lock is lost and I've moved a short distance left or right the gun will never find me without intervention. Seems like all of this could be fixed if I could control the search pattern???????

TDS with Ranger communication with Leica TPS 1105

by nonetootoughsurveys, Tuesday, April 26, 2011, 17:23 (1498 days ago) @ ps8182

Hey guys-

I've used a Leica TCRP 1201 with TDS Rangers for years. They work flawlessly with absolutely no kinks. I recently switched to a Leica TCRA 1105 Robotic gun and I'm running the TDS Ranger(s) (2) with versions 4.4.1 and the older 4.1.6. I just got the gun last night and finally got them to "talk". But all day long the gun would switch to tracking mode everytime I took a shot. The EGL lights kept coming on with every shot too, and the gun just beeped and beeped everytime it lost the prism. It would not let me turn off the lock and ATR at the same time. One or the other seemed to always have to be on.

I started a cheat sheet which I will cut and paste. If anyone has the proper settings, I would greatly appreciate it. Cause today sucked. LOL.

LEICA TCRA 1105 TO TDS RANGER COMMUNICATION SETTINGS

Leica instrument settings:

1) From the Main\ Main Menu:
• Select 5 Configuration.

2) In the Main\ Configuration menu:
• Select 2 Communication
mode.


3) From the Main\ Communication mode
menu:
• Select 1 GSI parameters.

4) In the Main\ GSI parameters screen:
• Baud rate: 19200.
• Protocol: GSI.
• Parity: None.
• Terminator: CR/LF.
• Data bits: 8.
• Stop bit: 1.
• Press the F1 (CONT) button to
set parameters.

5) In the Main\ Communication mode
• Select 2 GeoCom parameters.

6) In Main\ GeoCom parameters screen:
• Baud rate: 19200.
• Protocol: GeoCom
• Parity: None.
• Terminator: CR/LF.
• Stop bit: 1.
• Press the F1 (CONT) button to
set parameters.

7) From the Main\ Communication mode
menu:
• Select 3 GeoCom On-Line mode.


8) In GeoCom On-Line mode it will say:
“NOTICE 59”, “Switches to GeoCom on-Line mode.”, “Do you want to switch?”
• Choose: No.

9) From the Main\ Communication mode
menu:
• Select 4 RCS parameters.


10) In Main\ RCS parameters:
• Baud rate: 19200.
• Protocol: GeoCom
• Parity: None.
• Terminator: CR/LF.
• Data bits: 8.
• Stop bit: 1.
• Press the F1 (CONT) button to
set parameters.


11) From the Main\ Communication mode
menu:
• Select 5 Remote Control Mode.

12) In Remote control mode it will say:
“NOTICE 62”, “Switches to Remote Control mode.”, “Do you want to switch?”
• Choose: No.

13) Hit ESC then ESC again and go back to Main\ Main menu screen.

14) In Main\ Main menu screen choose: MEAS

TDS Ranger Instrument Settings:

1) In the main menu choose Job > Settings
2) In settings menu choose Instrument from the tabs on the top of screen.
3) In the middle, bottom of the screen choose Create New Instrument
4) Name: Leica TCRA 1105
Brand: Leica
Model: TPS Series
Serial Port: Com 1
Baud Rate: 19200
Parity: None
Now choose the box Instrument Settings in the middle left of screen
5) At the top of screen choose Correction
Horizontal Collimation: 0 (zero)
Vertical Collimation: 0 (zero)
6) At the same top of screen choose Mode
EDM Mode for Shots: IR Course
Use Guide light: Unchecked (no) Remote Mode: Unchecked (no)
Enable Motors: Checked (yes) GeoCom: Unchecked (no)
Power Search: Unchecked (no) GSI: Unchecked (no)
Send Ack in Record Mode: Unchecked (no)
Laser Pointer: Off
7) Choose Search box at top of screen
Horizontal Range: 2
Vertical Range: 2
Start Searching After: 999
Turning Type: Continuous
8) Hit the GREEN CHECK mark at the top right of screen to save your settings
9) Hit the GREEN CHECK again at the top right of screen to save your settings
10) Hit the GREEN CHECK again at the top right of screen to save your settings


YOU ARE READY TO SURVEY!!!!
TO TEST - TRY SENDING ZERO TO YOUR BS CIRCLE W/ THE RANGER
YOU MUST BE IN “MEAS” MODE ON THE LEICA TO USE THE RANGER

TDS with Ranger communication with Leica TPS 1105

by Joe M ⌂ @, MI, Tuesday, April 26, 2011, 17:42 (1498 days ago) @ nonetootoughsurveys

This doesn't happen with your TCRP 1200? Because the same thing happens on my 1203 as you are describing with your 1105, so I don't get how your new series is working and mine isn't. The only way I found to fix it is to disable the robotic mode in the TDS instrument settings (I am using it with a data collector with the TDS robotics module and figure it is related to this and some bad software assumption it makes). Disabling the robotics module has been the only way I have found to make the gun stick in ATR mode, but the TDS robot remote screen is of course missing, and TDS won't turn automatic repetition angles (instead TDS prompts me after every time the scope flips with the take the shot button, but at least it is flipping the scope and turning the gun for me). Having the robotics button checked on in the TDS instrument settings forced the Lecia to change to the track mode every time I take a shot, no matter what, even if I set the TDS to use the "on gun" prism modes. I am also using the latest version of survey pro that is free, 4.8.5, one that is much newer than yours. I too am interested in hearing from anyone who has this working, or anyone else who has this same problem. It just looks to me like the functionality was never really tested with newer Leica guns, and is probably using serial commands that only work correctly with older guns.

TDS with Ranger communication with Leica TPS 1105

by nonetootoughsurveys, Wednesday, April 27, 2011, 05:47 (1498 days ago) @ Joe M

Hey Joe M.

I'm off to work right now (5:30am), but I had my 1201 working perfectly with my TDS Ranger. I have a .spi file (instrument settings file) I can email you, along with the settings for the 1201. They shoud be the same for the Leica 1201, 1203 and 1205. Feel free to send me an reminder email today at jasonkrane@comcast.net. That way I can just attach the files and email you. I think we can get that Leica 1203 running flawlessly. I was doing 8-10 sets for the San Fransciso Bay Bridge Project control and I never had any of the problems you are talking about.

FYI, I got the Leica 1105 running flawlessly last night....finally. It was simply a lock setting in the gun. It would have been nice to have a manual in the field!!!!

Good luck,

Jason

TDS with Ranger communication with Leica TPS 1105

by nonetootoughsurveys, Sunday, May 22, 2011, 09:19 (1473 days ago) @ Joe M

Joe-

I tried to log on and reply at least 3 times since you posted this reply. I'm sorry. The site was doing maintenance and then I got busy trying to configure Leica 500 GPS units to work with the Ranger.

Please email me jasonkrane@comcast.net, I'll email you the cheat sheet. You may also call me if you want 925-667-5896 and I can set my gun up and we can walk through it one key at a time. I know what it's like ot have equipment on the blink when work needs to get done. I also put together a complete step-by-step cheat sheet that may help you. I have my TCRP 1203 working awsome with my TDS Ranger. I was using a Leica 1105 but then my boss drove from the Southern CA office last week and dropped off a complete Robotic TCRP 1203 in my lap that was not working with the Ranger or the Bantam x radios. I had to reconfigure everything from scratch and found the settings on this gun were not the same as the TCRP 1201 that I had used the previous 6 years!!! So there may be some slight differences. We can figure it out.

Cheers,

Jason

TDS with Ranger communication with Leica TPS 1105

by Joe M ⌂ @, MI, Sunday, May 22, 2011, 09:30 (1473 days ago) @ nonetootoughsurveys

I emailed you before, I will forward it to you again. I am still a skeptic though. ;)

RSS Feed of thread