Notifications
Clear all

[Solved] CARLSON BRX7 TILT IMU

8 Posts
6 Users
33 Likes
523 Views
Bsulliv1
(@bsulliv1)
Posts: 10
Member Member
Topic starter
 

I am having trouble with the IMU sensor on one BRX7 receiver.  The sensor seems to be stuck/won't initialize - only reads one tilt/incline angle - does not change.  The Carlson SURVPC IMU pole calibration screen reports that the sensor needs to be calibrated, but the calibration buttons are greyed out and not available, despite being fixed or "surefixed" and the "Correct Tilted Pole" being on, I always get the BLUE Warning icon unless I turn the tilt features off, defeating the purpose of the sensor. Any ideas? This particular receiver was working fine with the IMU/tilt until now. I performed a Hard Reset using SurvPC. Any other suggestions? Thank you, I am reaching out to my dealer as well.

 

 

 
Posted : August 17, 2022 9:02 am
Topic Tags
goodgps
(@goodgps)
Posts: 142
Member Member
 

Hi, 

check the satellite tracking to make sure the constellations are all turned on.  Also, check the DOP. When the DOP is less than ideal, the IMU won't work.  When I run into this, it forces me to turn the IMU off for a while. Most of the time, the constellation changes and the IMU works.   good luck 

 
Posted : August 17, 2022 9:50 am
whitey1371
(@whitey1371)
Posts: 30
Member Member
 

Hello,

I'm writing today to inform your members that are using a Carlson BrX7 and SurvCE/PC 6.15.  Over two weeks ago I discovered a malfunction in that particular software version when turning off 'Tilt Features' that could have drastic consequences as far as coordinate values and field work completed.

If you are locating anything with 'Correct Tilted Pole' feature activated and calibrated, and then turn off 'Tilt Features' completely, the BrX7 will apply the horizontal difference of however much the pole is tilted at that moment to the rest of your shots/positions.

While this at first might appear to be an easily noticed malfunction, it is not. Anything located after turning 'Tilt Feature' off will be horizontally and vertically correct relative to each other but not correct within whatever grid system you are using. 

Two separate crews on two separate jobs had checked into previously located points, only because of that did we find this malfunction, and the malfunction had those previous points +0.7' and +2.0' off from grid but inversing between them had "correct" values.

Turning off 'Tilt Features' off should normally reconfigure the BrX7 but for whatever reason it wasn't. Restarting the rover or switching job files did finally clear the tilt adjustment malfunction but, again, not knowing of the malfunction one might not do that.

SurvCE/PC 6.15 was released on June 30, 2022 and this malfunction was brought to Carlson's attention on July 27. They released a new version, 6.16,.on August 1 but the release notes for the update don't accurately describe the severity of the malfunction that was fixed. As far as I know, the Carlson user community has not been notified of this malfunction and the potential error that goes along with it. Recorded plans could be wrong, buildings might be laid out incorrectly and general inaccuracies could incur.

Again, we only noticed this malfunction because of checking into previously located points. We have been spending a lot of time and energy looking into all the work we've done with version 6.15 to see if projects need to be verified and reshot.

It's my hope that you pass this information onto your members. I understand that the number this malfunction might affect is small, but it is serious and over six weeks of work could be in jeopardy.

Thank you,

Michael A. Kirkpatrick

 
Posted : August 17, 2022 11:55 am
Jaccen, Bsulliv1, Brad Ott and 4 people reacted

Get the 2023 SurveyorConnect Wall Calendar

Ladd Nelson
(@ladd-nelson)
Posts: 731
Member Member
 
Posted by: @bsulliv1

I am having trouble with the IMU sensor on one BRX7 receiver.  The sensor seems to be stuck/won't initialize - only reads one tilt/incline angle - does not change. Thank you, I am reaching out to my dealer as well.

My suggestion would be (while IMU is enabled) to invert the receiver so it is forced to reacquire the satellite signals. I've also found moving about with the receiver (say 20 - 30 ft) while in a Fixed GNSS solution is usually sufficient to initialize the IMU.

I hope this information helps.

 
Posted : August 17, 2022 3:01 pm
Bsulliv1, Brad Ott, Bsulliv1 and 3 people reacted
Sergeant Schultz
(@sergeant-schultz)
Posts: 884
Member Member
 

We are (almost) ALL of us paying BETA testers.

 
Posted : August 17, 2022 3:03 pm
Jaccen, Bsulliv1, leegreen and 7 people reacted
Ladd Nelson
(@ladd-nelson)
Posts: 731
Member Member
 
Posted by: @whitey1371

Hello,

I'm writing today to inform your members that are using a Carlson BrX7 and SurvCE/PC 6.15.  Over two weeks ago I discovered a malfunction in that particular software version when turning off 'Tilt Features' that could have drastic consequences as far as coordinate values and field work completed.

If you are locating anything with 'Correct Tilted Pole' feature activated and calibrated, and then turn off 'Tilt Features' completely, the BrX7 will apply the horizontal difference of however much the pole is tilted at that moment to the rest of your shots/positions.

While this at first might appear to be an easily noticed malfunction, it is not. Anything located after turning 'Tilt Feature' off will be horizontally and vertically correct relative to each other but not correct within whatever grid system you are using. 

Two separate crews on two separate jobs had checked into previously located points, only because of that did we find this malfunction, and the malfunction had those previous points +0.7' and +2.0' off from grid but inversing between them had "correct" values.

Turning off 'Tilt Features' off should normally reconfigure the BrX7 but for whatever reason it wasn't. Restarting the rover or switching job files did finally clear the tilt adjustment malfunction but, again, not knowing of the malfunction one might not do that.

SurvCE/PC 6.15 was released on June 30, 2022 and this malfunction was brought to Carlson's attention on July 27. They released a new version, 6.16,.on August 1 but the release notes for the update don't accurately describe the severity of the malfunction that was fixed. As far as I know, the Carlson user community has not been notified of this malfunction and the potential error that goes along with it. Recorded plans could be wrong, buildings might be laid out incorrectly and general inaccuracies could incur.

Again, we only noticed this malfunction because of checking into previously located points. We have been spending a lot of time and energy looking into all the work we've done with version 6.15 to see if projects need to be verified and reshot.

It's my hope that you pass this information onto your members. I understand that the number this malfunction might affect is small, but it is serious and over six weeks of work could be in jeopardy.

Thank you,

Michael A. Kirkpatrick

I was alerted by one of my regional dealers that one of the regional State Surveyor societies was sent this message above resulting in statements from Society members who indicated:

I'll defer to [Society President] on the final say on this but I have some concerns about this email. The content of the email sounds legit and urgent but should be verified for authenticity...

and:

Appreciate his willingness to share this message with us but need to make sure we are not passing on incorrect information or possible spam.

I directly addressed the members within the Email chain acknowledging that the cited SurvCE/SurvPC was, in fact, legitimate along with the suggested corrective measure of upgrading to SurvCE/SurvPC 6.16.

While performing my own research today, it appears that simply re-processing the "raw" (*.RW5) file (either with SurvCE/SurvPC or with the Edit-Process Raw File command found in Carlson Survey) will generate correct coordinates. The Carlson development team are continuing their research and it appears the re-process approach solves the problem in these scenarios:

  • single epoch measurement situations,
  • multi-epoch measurement situations with a stationary pole (both during IMU and without IMU), and,
  • multi-epoch measurement situations with a wobbly pole during IMU and a stationary pole without IMU (I tested this to simulate a scenario where the receiver might be over some type of aquatic/wavy condition and not able to be held steady).

In each of my tests, I was not using any type of stabilization (e.g. bipod) during the IMU and non-IMU measurements.

I'd further like to state this appears to be purely a SurvCE/SurvPC software issue and able to be corrected without having to re-measure anything. From what I've been able to tell, the BRx7 has been functioning correctly in this situation and I would strike the following from the above:

turn off 'Tilt Features' completely, the BrX7 will apply the horizontal difference

(it is/was SurvCE/SurvPC that was applying the differences to the coordinate file) Also:

Turning off 'Tilt Features' off should normally reconfigure the BrX7 but for whatever reason it wasn't.

(it did reconfigure the BRx7 as tilt records do not occur in the RW5 file after IMU was suspended [at least in my testing])

Again, the Carlson product development team are continuing their research and any official news will come through the Carlson web-site and/or subscriber update notification system.

I hope this information helps.

 
Posted : August 17, 2022 3:48 pm
Jaccen, Bsulliv1, Bsulliv1 and 1 people reacted

Get the 2023 SurveyorConnect Wall Calendar

Bsulliv1
(@bsulliv1)
Posts: 10
Member Member
Topic starter
 

Solved. Thank you all for your replies. Usually the IMU will initialize within a few minutes of turning on or moving about, but this time it wouldn't budge over several locations/days.  At the suggestion of my dealer, I reset the receiver using the WEB UI (rather than SurvPC) and reset to the factory defaults( WEB UI again). I also installed SurvPC ver. 6.16 on my RT4 data collector. I was again able to calibrate the ebubble and pole tilt, and it appears to be working again! I was running SurvPC release 6.14, so I am not sure if my issue was related to the potential errors found in release 6.15. I do appreciate the in depth discussion of possible problems and solutions from both the users and the developers. This forum has always been great.  

Thanks again,

Brendan

 
Posted : August 17, 2022 4:34 pm
hpalmer
(@hpalmer)
Posts: 343
Member Supporter
 

What versions of surv PC?  We use a non-Carlson gnss and export our data.  We use 6.06.  

 
Posted : August 17, 2022 6:00 pm